NBash
93 строки · 2.6 Кб
1Summary: An high level argument parsing library for bash
2Name: bash-argsparse
3Version: 1.8
4Release: 1%{?dist}
5License: WTFPL
6URL: https://github.com/Anvil/bash-argsparse
7Source0: http://argsparse.livna.org/%{name}-%{version}.tar.gz
8BuildArch: noarch
9# Binaries are required for unittest to perform cleanly.
10BuildRequires: doxygen glibc-common util-linux /usr/bin/host
11
12Requires: bash >= 4.2
13Requires: util-linux glibc-common /usr/bin/host
14
15%description
16An high level argument parsing library for bash.
17
18The purpose is to replace the option-parsing and usage-describing
19functions commonly rewritten in all scripts.
20
21This library is implemented for bash version 4. Prior versions of bash
22will fail at interpreting that code.
23
24%prep
25%setup -q
26
27%build
28# Nothing to build, except the documentation.
29doxygen
30
31%install
32mkdir -p $RPM_BUILD_ROOT/%{_bindir}
33for file in argsparse argsparse-completion; do
34install -m 0755 "$file.sh" $RPM_BUILD_ROOT/%{_bindir}
35ln -s "$file".sh $RPM_BUILD_ROOT/%{_bindir}/"$file"
36
37%check
38./unittest
39
40%files
41%doc tutorial README.md html COPYING
42%{_bindir}/argsparse*
43
44
45%changelog
46* Tue Sep 5 2017 Dams <bash-argsparse[AT]livna.org> - 1.8-1
47- Version 1.8
48
49* Thu Mar 5 2015 Dams <bash-argsparse[AT]livna.org> - 1.7-1
50- Version 1.7
51
52* Wed Jan 28 2015 Dams <bash-argsparse[AT]livna.org> - 1.6.2-1
53- Version 1.6.2
54- Dropped fedora patch (included upstream)
55
56* Fri Oct 24 2014 Dams <bash-argsparse[AT]livna.org> - 1.6.1-3
57- Using package names instead of path for Requires/BuildRequires
58
59* Wed Oct 15 2014 Dams <bash-argsparse[AT]livna.org> - 1.6.1-2
60- Added patch to fix some unittest issues
61
62* Thu Oct 9 2014 Dams <bash-argsparse[AT]livna.org> - 1.6.1-1
63- Version 1.6.1
64- Fixed changelog names
65
66* Thu Oct 9 2014 Dams <bash-argsparse[AT]livna.org> - 1.6-4
67- Update host path in *Requires tags.
68
69* Wed Oct 8 2014 Dams <bash-argsparse[AT]livna.org> - 1.6-3
70- Added more BuildRequires to allow unittest script to run correctly
71restricted small environments
72
73* Mon Sep 15 2014 Dams <bash-argsparse[AT]livna.org> - 1.6-2
74- Fixed date in changelog entry
75
76* Tue Aug 12 2014 Dams <bash-argsparse[AT]livna.org> - 1.6-1
77- License tag is now WTFPL
78- Removed trailing dot at the end of Summary
79- Removed BuildRoot tag
80- Requiring commands instead of packages
81
82* Mon Jan 13 2014 Dams <bash-argsparse[AT]livna.org> - 1.6-0
83- Version 1.6
84- Added doxygen documentation
85- check section
86
87* Thu Mar 21 2013 Dams <bash-argsparse[AT]livna.org> - 1.5-0
88- Version 1.5
89- Updated Requires
90- Removed old/fedora-obsolete directives/noise
91
92* Thu Mar 14 2013 Dams <bash-argsparse[AT]livna.org> - 1.4-0
93- Initial build.
94